Security Hero Rotating Header Image

1415 (gnutls)

CVE-2009-1415 (gnutls)

lib/pk-libgcrypt.c in libgnutls in GnuTLS before 2.6.6 does not properly handle invalid DSA signatures, which allows remote attackers to cause a denial of service (application crash) and possibly have unspecified other impact via a malformed DSA key that triggers a (1) free of an uninitialized pointer or (2) double free.

URL: http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2009-1415

Leave a Reply

Your email address will not be published. Required fields are marked *